Sometimes I just feel really, frickin’ stupid… ūüí©

I’ve kept a tiny secret from my boyfriend, and basically everybody else as well, but I had to change hosts. Again. I said I was going to a while back, because the web host I chose during the early spring sucked balls and I got really so annoyed with them that I started looking for another one practically immediately. I found a new one, they’re called “Egensajt” which basically means “Your own site” or “your website” cramped into one word. They are also very cheap, they provide SSL easily with let’s encrypt and also provide a bunch of other useful stuff I plan on starting using later, WP-cli, SSH and git.

WTF is going on in my mind lately? Well, (not)learning to code and shitty web hosts and the struggles to find the energy to focus on the right thing!

However, my trip over here hasn’t been the greatest either, due to me being an idiot, but I guess everything is fine now at least. I’ve spammed the support a gazillion times for the past weeks since I started my account there, because I’ve struggled a bit with the move of other domains, the obligate down time while moving a website, installations of Drupal, WordPress Multisite and Limesurvey and a few other things.

The good things are though that, except for the Drupal problems(I’ll get to that one later), all the other issues are fixed and were basically down to two things; Me, having a brain that requires that everything should happen in an instant and me being (yet again) a complete, uneducated n00b regarding techie stuff.

All of this have just taught me that I really need to learn how to code, so I can understand all of this fun stuff for real, but I haven’t been able to find the energy for that all spring, basically. I’ll explain a bit more below, but I have my reasons for doing all this, even though it’s practically unnecessary…

I realized that you can’t have folder listing or anti-hotlink (or whatever it’s called) activated if you want to install php applications with your web host. I had no idea about that! Folder listings make php apps to not activate, and anti hotlink makes you get broken images if you’ve got SSL activated.

I also had the problem with WordPress. Like I’ve mentioned before¬†my setup is basically this:

  • I have a multisite install where all my public blogs and websites live, except for this one at the moment.
  • I have another WP multisite on a separate subdomain where I do all the testing for the main site.
  • I have this install for this single domain, that has moved around a bit, but will probably stay as a single install and separate from the others just because it’s for the best. I think.
  • I create other various subdomains and use other domains from other web hosts I’ve registered that I use for testing purposes. Most of them are WP related, but some are for other PHP clients, like Drupal and Limesurvey.

Since moving to yet another host, I’ve tried to have my normal setup and I finally got everything to work, but Drupal did not work like it should for some strange reason. The reason I wanted to play around with Drupal is due to a thing at work. I got an idea and figured out that Drupal can basically solve everything, but sadly my proposal was denied for now which basically just made me more upset ūüė¶ . I did most of the Drupal testing at my previous host (Inleed) while I was waiting for the main domain to move over to the new host. Then, as I got to the new host, Drupal did not work. It was practically impossible to install it, because I fell into the classic Drupal trap where I got access denied, even though I was the admin and everything. In the end I had to ask the web host to install it for me, but it was to no avail.

During all of this I had also installed Limesurvey and the test sites, but no matter what I did the templates from the clients, aka the text inside the php files where showing when I visited the url and I could not install, or login. Turned out, like I mentioned above that this was due to the folder listing being activated. When I turned it off I could install the applications. Then the other issues came up…

First of all I noticed that the clients had broken images when I viewed the sites with SSL. After a bit of googling again, I discovered that it was due to the anti-hotlinking was activated. Also I had problems with wildcard…

Yesterday I noticed that my testing site did not have an .htaccess any longer and the network settings had vanished. This I have no idea why it happens, but as I’ll explain what happened below, maybe these two are related?

In order to use WordPress Multisite you have to setup a wildcard A record in your dns setting. The thing is, I’ve done that like a billion times and I know what it is. The difference is that with this new host, I thought I’d done that correctly, but I had not. I did not set the wildcard as a dns record. Instead my web host turned the wildcard as an alias for my main domain. I also had no idea there was a difference! When I changed it from an alias to a proper A record wildcard dns, I could access my sites again. The old problem of the redirect thing happened again until this was changed and I felt depressed and like a total idiot while I couldn’t figure this out. I also decided I did not want to bother the support again either, even though they get paid to help me out. I just want stuff to work!

The only problem I have now is that WordpPress – all of my installs are incredibly slow when it comes to updating plugins, the core and saving post and other changes. Otherwise it’s pretty fast and works well. I upgraded the PHP memory to 256 MB, and I’ve also activated the Memcached that this web host has. I also turned on Varnish Cache that’s also an option here. So far it has helped a little, but it’s still extremely slow when I want to install or upgrade something. I just hope that this post will publish as usual to social media as well. Maybe it’ll work properly in a day or two…

An important note!

The reason for me switching host once again is due to several reasons. I said that I’d probably do this in a couple of months and that was the truth. I’ve had a really painful spring at work and also in my private life and playing around with php clients, like WordPress and my newly found interest in learning code really helps with not feeling bored and/or restless as fuck.

I still should point out, that me wanting to learn code has turned into crap, basically which is not surprising due to all my illnesses and how my mind works. I have made up my mind that I’m gonna finish the C# class I started a while back, but I’ve been way to tired to focus on that, due to a gazillion other stuff going on that steals my thunder. I really hate it, because I’m so into this. It feels like the right time is now to start a new beginning, but I guess I won’t be able to until I’m not this tired anymore and there are no other problems lurking around the corner… I can’t really explain this tiredness either. I just feel it and the only thing that helps are shitty crap-stuff with the usual stuff. Aka, playing around with code and knowing nothing with WP, Drupal and Limesurvey being the test subjects as of today.

I’d like to learn as much as possible, but everywhere I turn – there’s trouble for some reason – because I don’t understand code! I’ll probably blog a bit more about it later, and for those who understand Swedish, I’ll make a post soon as well to explain myself a bit more. Basically, I’m stuck in a circle and I’m doing what I can to keep up and not lose my mind, but no matter what I do, I feel bored, lost or angry and disappointed.

In less than a few weeks, me and the BF will move to another apartment that’s closer to everything and I bet that after having a long vacation from work, I’ll find my strength somehow. I think living right where we live now is one small contributing factor to why I feel like i have these past months. I really thought it was gonna be a life changer, but all the move to this exact place was, was nothing but meh. Besides living more to the south in Sweden and having the luxuries of living so close to Malm√∂, it’s not been that great. After the move I hope I’ll learn to code a bit more and hopefully I can focus more on blogging instead of struggling like I have AND need to in order to feel a little like myself these days.

Thanks for reading this far!

Advertisements

Throwback Thursday on a Monday…

In this post I shall go over all of the posts I’ve written since I started this blog again during the early summer of 2016. I’ve noticed that I need to update some stuff, so fetch some popcorn and get to readin’ because now I’m starting.

I really do not recommend DirectAdmin as a control panel

If you’re like me and you’re pretty much obsessed with blogging, (and really lousy at coding), you know that a proper web host is a must for hosting applications such as WordPress. There are tons out there to choose from and I think I’ve tried nearly all of them. At least it really does feel like I have during my years of blogging and being present online.

Oh, the struggles I’ve been having with my current web host and Direct Admin as a control panel… Oh, the horrors…

I started blogging for real with WP in the beginning of 2009. Since then I’ve changed web hosts and blogging platforms as often as a parent would change their kid’s diapers or something. I really do not know why I’ve done this so much, but now that I am more experienced and know a little bit more about what I personally need – I do not recommend switching hosts every so often. Do your research and stick with a great host to begin with.

A proper web host should have this:

  • cPanel as their choice of control panels. DirectAdmin works, but it effin’ sucks for various reasons. It could also be my web host’s fault, but I do not know.
  • Offer WP as both single installs and multisite with wildcards (*). As a user, a wildcard being added to your dns settings is all you should ever have to care about.
  • be able to point a domain to a folder of your choice; I.E point sub.example.com to user/domains/example.com/public_html/sub without any hassle. ¬†This also includes add-on domains and aliases.
  • Free SSL support that works for both subdomains and top level domains.
  • Full access to the database. With this I mean so you can change the table prefix etc. Also one login to rule them all or something. Not one user AND a database for every frickin’ login.
  • Being able to install WP (for example) manually, like the famous 5 minute install, as well ass offer a 1 click service.
  • Backups that do not drain your space every 5 minutes or something.

There are many, many other things as well that a proper web host should offer and the things mentioned above is what I personally need and prefer.

My struggle…

Like I mentioned before, I’ve struggled for various reasons with my web hosts of choice. In the beginning I changed hosts basically because I thought I had to or I did it for some other stupid reason. When I got to know WP for what an awesome thing it really is and when Multisite was introduced, I changed web hosts for other reasons and always thought that “this would be the final one”. Eh… that only lasted for so long…

All that finally changed, when I partly quit being an idiot and stuck with WP for ever and discovered a Swedish web host that almost did it’s job perfectly. I stayed with them for nearly 3 years. They were called Binero. Then, a few months back I started noticing that my blogs in my WP installations did not have SSL. I basically thought they did, but it was probably a Chrome extension that fooled me, because I started noticing this when that extension stopped working. It became a big deal to change hosts, and I finally switched to another Swedish based host. They’re called Inleed and they are almost illegally cheap, but you get what you pay for…

The move went fine, but almost from the start I’ve had problems and they haven’t gone away completely yet.

The issues

This is what I’ve had to deal with so far. A real pain in the butt…

  • Not being able to install anything on general subdomains, especially with SSL.
  • I’ve added subdomains as i.e sub.example.com but not been able to access the subdomain at that level, only at domain.com/sub which effin’ sucks balls! However, if I do this – everything works as it should, I get SSL etc but it’s not a pretty sight and makes subdomains completely useless.
  • Redirection issues to my main WP install if I have installed something on SSL. Even though I have separate installs this happens! For example; my main WP install is a multisite at domain.com and I created a WP multisite install for testing purposes at test.domain.com. If this test install is installed on SSL, it redirects or is not found at test.domain.com and it redirects to domain.com to the signup page or whatever other page I’ve set NOBLOGREDIRECT to. So frustrating!
  • I had to contact support in order to get WP multisite to work – which in part also created all the other issues I’ve been having.
  • The support have been struggling as well with my domains and subdomains, not answered all of my questions as far as I can tell, because I felt somewhat ignored sometimes. They may have read it all, but have chosen to only answer one question in a long email.
  • I do not have complete access either to my files, since I’m “only” a user. I do not know if it’s possible to upgrade, since I’ve asked about this and did not get an answer. Every time I need to “fix” something, I have to ask the support to edit the httpd.conf files etc and I do not like that.

After weeks of struggling I finally got proper help and I got my main installs I want to function properly, but I still can’t install anything properly on SSL, even though I finally can use real subdomains like you should always be able to. I will be contacting the support soon, after I’ve done some more testing.

The Conclusion:

Well, basically I’m getting tired of this shit and a couple of weeks ago I decided that I will be downsizing my web hosting affairs a bit, which means I shall stick to simple blogging instead and I will start to learn to code for real. Don’t worry, I sticking to WP! What I mean is that I shall try and not hassle that much with my blogs and instead I’ll keep on writing good posts.

I’ve started to learn C# in order to give me something I really can use, and when I’m done with that I shall try to create games for both desktop and android using Unity. After that I shall also try and learn C++ and maybe .NET as well. All done in my spare-time of course, but if I succeed with this I might start to work with it later on in a few years. Who knows? All I know is – choose your web host carefully and stick to WP whenever possible if you’re a blogger like me and like control over your shit.

 

Solving a redirect login issue with WordPress can take months…

And still it doesn’t mean that it has been solved or is about to. With this post I’m writing today, with nearly two whole months of being absent from my awesome blog in English, I’m keeping my hopes up that I have for once solved this crap and never have to bother with multisite issues (MS rocks otherwise!), cookies, redirects and not getting access or getting angry or upset.

Ze background…

I’m using WordPress to do my blogging. No secret there. I have currently 4 blogs, and three of them are active. It’s this one, my Swedish one and the Swedish one about Great Danes. My website is just a basic website with my CV, and career updates and I also have created an archive of my old blog in Swedish, which contains of posts written since January of 2009 and has been made and moved through out basically all blogging platforms out there. Now it serves as an archive because here on WordPress, I’ve made the decision two years ago to never, ever change blogging platforms again. Tumblr is not an active platform either…

Caring for multiple blogs in a great way…

Ever since Multisite became a reality in 2010 with the 3.0 update, I’ve been using it pretty steadily whenever I’ve used WordPress as my platform. Now, it’s really useful because I have 3 active blogs that I like to update as often as possible. No matter what, I regularly login to my Swedish personal blog almost daily and with that I also check in on my other blogs to see stats, look for spam or other issues so I basically hop around a lot. Until I started this blog (again) which is on a whole ‘nother domain, this was not a problem at all. But, when I got this domain back, I thought that I’d of course would like to have my blog together with all the others in my multisite install. And then came the cookie issues…

Cookies, logins and redirects, oh my…

WordPress is awesome. It can handle multiple domains without a plugin, so no domain mapping is necessary. That’s indeed great! So far so good. Well. Not for long. It’s pretty simple to setup, just change the site_url and you’re good to go. The issue is with cookies. Half-Elf has written a post on how to solve this and so have many others. I’ve tried basically everything, because since I seem to hop from blog to blog whenever I login to one of them, it’s a real frickin’ hassle to keep logging in to every, goddamn blog. I know it’s safer this way, but still. I’m like this close to ripping my hair out and throwing my computer out of the window due to¬†sticky stuff like this. Me not like problems.

What I’ve tried in order to solve this mess…

  1. ¬†Everything in Half-Elfs’s post that I mentioned before.
  2. Created multiple networks with the WP Multi Networks plugin and moved this blog over there.
  3. Moved the blog to a separate WP install, once with separate database, another time with separate tables in the same WP install (with shared users table).
  4. Tested with other domains on a test install to change from subdomains to subdirectory and with that I also changed the home_url, but kept a subdirectory url for backend purposes. This seems like the best way, but I hate the look of subdirectories…
  5. Trying as we write to only have this in my wp-config.php file regarding cookies, with the blog being part of multisite and on the correct url everywhere (aka both home and site url are the same and everything else is as it should be for MS setup).
    define( 'COOKIE_DOMAIN', $_SERVER[ 'HTTP_HOST' ]);

As of now, nothing has worked. It always has worked “for a while”. But after a few hours, days etc. it stops working. After the update to 4.6 my whole multisite install seemed to totally bug out. No matter what I did I had to login all the frickin’ time to even my subdomains! That was really annoying. And then I hadn’t changed a thing, except for the solution from Tom McFarlin! That solution, however, worked “somewhat”. It was a solution I could settle with. It meant that I could sign in to one of my subdomains once – and always be logged in to all my other subdomains, but whenever I had to access this blog on a separate domain, that’s when I had to login again. After the update to 4.6 this did not work so I had to start looking yet again for another solution.

With the plugin, I also added this to my wp-config.php file:
// Cookies
define( 'COOKIEHASH', md5( 'yourdomain.com' ) );
define( 'COOKIE_DOMAIN', 'yourdomain.com' );
define( 'ADMIN_COOKIE_PATH', '/' );
define( 'COOKIEPATH', '/' );
define( 'SITECOOKIEPATH', '/' );
define( 'TEST_COOKIE', 'thing_test_cookie' );
define( 'AUTH_COOKIE', 'thing_' . COOKIEHASH );
define( 'USER_COOKIE', 'thing_user_' . COOKIEHASH );
define( 'PASS_COOKIE', 'thing_pass_' . COOKIEHASH );
define( 'SECURE_AUTH_COOKIE', 'thing_sec_' . COOKIEHASH );
define( 'LOGGED_IN_COOKIE', 'thing_logged_in' . COOKIEHASH );

And I also added/changed this:
// Multisite
define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
define( 'PATH_CURRENT_SITE', '/' );
define( 'DOMAIN_CURRENT_SITE', $_SERVER['HTTP_HOST'] );
// Likely not needed anymore (your config may vary)
//define( 'SITE_ID_CURRENT_SITE', 1 );
//define( 'BLOG_ID_CURRENT_SITE', 1 );
// Uncomment and change to a URL to funnel no-site-found requests to
//define( 'NOBLOGREDIRECT', '/404/' );
/**
* These are purposely set for maximum compliance with multisite and
* multinetwork. Your config may vary.
*/
define( 'WP_HOME', 'https://' . $_SERVER['HTTP_HOST'] );
define( 'WP_SITEURL', 'https://' . $_SERVER['HTTP_HOST'] );

Now I’m just hoping that this setting has solved it. I do not believe so. Not in the long run at least. If it stays the same until tomorrow, I might be able to let this one go. When I think it is solved it means that I can continue to hop around to and from every blog without the hassle of logging in every time. If it works the way it usually does, it means that I can do this for a couple of hours, days or maybe just until I close my browser and try to login again to one of my blogs. Often, however I’m getting the redirect loop where it’s impossible to even access any dashboard and that happened earlier today. I just hope it was due to another mistake I made, regarding changing the site or home url. Everything at the moment is the way it should be, and that’s good. This blog doesn’t get any viewers anyways. 4 in one day is like totally amazing stats! But I’ve stopped caring about that. Or at least I try to…

I just really hope it stays this way now. The only dislike I have about every blogging platform out there (yes, even WordPress) are those tiny, little things that makes it difficult to get everything I want out of a platform. It’s all due to me of course being a noob, who hasn’t learned how to code. All I do is copy and paste. I have not learned the terminology and I have no idea what the Frick I’m talking about. All I know when I’m creating the snippets for my WP blogs is what I want the result to be. I’ve solved many issues and a lot of them are baked right into WordPress itself (i.e. Custom Fields, categories and tags). I’ve managed to create single posts whenever I post something on Instagram and shipping them over here, thanks to If This Then That and a simple trick using Jetpack’s Post by Email module. Amongst other things. Fingers crossed that this shit works now. Otherwise I’ll lose my mind a little bit more…